Back to overview
Resolved
Scheduled ReignDC Control Panel Maintenance
Sep 13, 2026 at 1:30pm UTC
–
Sep 13, 2026 at 2:30pm UTC
Affected services
Game Panel
Resolved
Sep 13, 2026 at 2:30pm UTC
Maintenance ended
Affected services
Created
Sep 13, 2026 at 1:30pm UTC
We will be performing scheduled maintenance on the ReignDC Control Panel from 7:00 PM to 8:00 PM IST.
During this maintenance window, the control panel may be temporarily unavailable while we update Pterodactyl and Blueprint to their latest versions and perform system optimizations.
Hosted services are expected to remain unaffected. Panel access and management functionality may be temporarily unavailable during the maintenance.
We will provide an update once maintenance is completed.
Affected services